Tuesday 16 April 2013

JunOS: VRF configuration over MPLS

Scenario using static mapping for lsp


  • P configuration:


set protocols rsvp interface all
set protocols mpls label-switched-path TO_PE2 from 1.1.1.1
set protocols mpls label-switched-path TO_PE2 to 2.2.2.2
set protocols mpls label-switched-path TO_PE2 no-cspf
set protocols mpls label-switched-path TO_PE1 from 2.2.2.2
set protocols mpls label-switched-path TO_PE1 to 1.1.1.1
set protocols mpls label-switched-path TO_PE1 no-cspf
set protocols mpls interface all

set interfaces em0 unit 0 family inet address 172.20.1.6/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 172.20.1.10/30
set interfaces em1 unit 0 family mpls

set routing-options static route 1.1.1.1/32 next-hop 172.20.1.5
set routing-options static route 2.2.2.2/32 next-hop 172.20.1.9
  • PE1 configuration:
set interfaces em0 unit 0 family inet address 172.20.1.1/30
set interfaces em1 unit 0 family inet address 172.20.1.5/30
set interfaces em1 unit 0 family mpls
set interfaces lo0 unit 100 family inet address 1.1.1.1/32

set routing-options static route 2.2.2.2/32 next-hop 172.20.1.6
set routing-options router-id 1.1.1.1
set routing-options autonomous-system 1111

set protocols rsvp interface all
set protocols mpls label-switched-path TO_PE2 from 1.1.1.1
set protocols mpls label-switched-path TO_PE2 to 2.2.2.2
set protocols mpls label-switched-path TO_PE2 no-cspf
set protocols mpls interface all

set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL peer-as 1111
set protocols bgp group INTERNAL neighbor 2.2.2.2 local-address 1.1.1.1
set protocols bgp group INTERNAL neighbor 2.2.2.2 family inet-vpn unicast

set routing-instances VPNA instance-type vrf
set routing-instances VPNA interface em0.0
set routing-instances VPNA route-distinguisher 100:1
set routing-instances VPNA vrf-target target:100:1
set routing-instances VPNA vrf-table-label
set routing-instances VPNA protocols bgp group VPNA neighbor 172.20.1.2 peer-as 2222
  • PE2 configuration:
set interfaces em0 unit 0 family inet address 172.20.1.9/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 172.20.1.13/30
set interfaces lo0 unit 100 family inet address 2.2.2.2/32

set routing-options static route 1.1.1.1/32 next-hop 172.20.1.10
set routing-options router-id 2.2.2.2
set routing-options autonomous-system 1111

set protocols rsvp interface all
set protocols mpls label-switched-path TO_PE1 from 2.2.2.2
set protocols mpls label-switched-path TO_PE1 to 1.1.1.1
set protocols mpls label-switched-path TO_PE1 no-cspf
set protocols mpls interface all

set protocols bgp group INTERNAL type internal
set protocols bgp group INTERNAL peer-as 1111
set protocols bgp group INTERNAL neighbor 1.1.1.1 local-address 2.2.2.2
set protocols bgp group INTERNAL neighbor 1.1.1.1 family inet-vpn unicast

set routing-instances VPNA instance-type vrf
set routing-instances VPNA interface em1.0
set routing-instances VPNA route-distinguisher 100:1
set routing-instances VPNA vrf-target target:100:1
set routing-instances VPNA vrf-table-label
set routing-instances VPNA protocols bgp group VPNA neighbor 172.20.1.14 peer-as 3333
  • CPE1 configuration:
set interfaces em0 unit 0 family inet address 172.20.1.2/30
set interfaces em1 unit 0 family inet address 10.11.12.13/24
set interfaces lo0 unit 100 family inet address 100.100.100.100/32

set routing-options router-id 172.20.1.2
set routing-options autonomous-system 2222

set policy-options policy-statement LOCAL_CONNECTED term loopback0 from instance VPNA
set policy-options policy-statement LOCAL_CONNECTED term loopback0 from protocol direct
set policy-options policy-statement LOCAL_CONNECTED term loopback0 then accept

set routing-instances VPNA instance-type virtual-router
set routing-instances VPNA interface em0.0
set routing-instances VPNA interface lo0.100
set routing-instances VPNA protocols bgp group VPNA type external
set routing-instances VPNA protocols bgp group VPNA export LOCAL_CONNECTED
set routing-instances VPNA protocols bgp group VPNA neighbor 172.20.1.1 peer-as 1111
  • CPE2 configuration:
set interfaces em0 unit 0 family inet address 172.16.48.178/24
set interfaces em0 unit 0 family inet address 172.20.1.14/30
set interfaces em1 unit 0 family inet address 10.11.12.13/24

set routing-options router-id 172.20.1.14
set routing-options autonomous-system 3333

set policy-options policy-statement LOCAL_CONNECTED term loopback0 from instance VPNA
set policy-options policy-statement LOCAL_CONNECTED term loopback0 from protocol direct
set policy-options policy-statement LOCAL_CONNECTED term loopback0 then accept

set routing-instances VPNA instance-type virtual-router
set routing-instances VPNA interface em0.0
set routing-instances VPNA interface lo0.100
set routing-instances VPNA protocols bgp group VPNA type external
set routing-instances VPNA protocols bgp group VPNA export LOCAL_CONNECTED
set routing-instances VPNA protocols bgp group VPNA neighbor 172.20.1.13 peer-as 1111

  • Verification: 
root@PE1> show bgp summary
Groups: 2 Peers: 2 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
bgp.l3vpn.0            3          3          0          0          0          0
inet.0                 0          0          0          0          0          0
Peer               AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Damped...
172.20.1.2       2222         64         67       0       0       27:57 Establ
  VPNA.inet.0: 1/2/0

2.2.2.2          1111        134        135       0       1       57:35 Establ
  bgp.l3vpn.0: 3/3/0

  VPNA.inet.0: 3/3/0

root@PE1> show route table VPNA.inet.0
VPNA.inet.0: 6 destinations, 7 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
100.100.100.100/32 *[BGP/170] 00:16:55, localpref 100
                      AS path: 2222 I
                    > to 172.20.1.2 via em0.0
172.16.48.0/24     *[BGP/170] 00:12:10, localpref 100, from 2.2.2.2
                      AS path: 3333 I
                    > to 172.20.1.6 via em1.0, label-switched-path TO_PE2
172.20.1.0/30      *[Direct/0] 01:07:41
                    > via em0.0
                    [BGP/170] 00:16:55, localpref 100
                      AS path: 2222 I
                    > to 172.20.1.2 via em0.0
172.20.1.1/32      *[Local/0] 01:07:41
                      Local via em0.0
172.20.1.12/30     *[BGP/170] 00:29:20, localpref 100, from 2.2.2.2
                      AS path: I
                    > to 172.20.1.6 via em1.0, label-switched-path TO_PE2
200.200.200.200/32 *[BGP/170] 00:11:35, localpref 100, from 2.2.2.2
                      AS path: 3333 I
                    > to 172.20.1.6 via em1.0, label-switched-path TO_PE2

 root@CPE1> show bgp summary
Groups: 1 Peers: 1 Down peers: 0
Peer               AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Damped...
172.20.1.1       1111         71         71       0       0       30:10 Establ
  VPNA.inet.0: 3/3/0

VPNA.inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
100.100.100.100/32 *[Direct/0] 00:34:10
                    > via lo0.100
172.16.48.0/24     *[BGP/170] 00:13:36, localpref 100
                      AS path: 1111 3333 I
                    > to 172.20.1.1 via em0.0
172.20.1.0/30      *[Direct/0] 00:34:10
                    > via em0.0
172.20.1.2/32      *[Local/0] 00:34:10
                      Local via em0.0
172.20.1.12/30     *[BGP/170] 00:30:34, localpref 100
                      AS path: 1111 I
                    > to 172.20.1.1 via em0.0
200.200.200.200/32 *[BGP/170] 00:13:02, localpref 100
                      AS path: 1111 3333 I
                    > to 172.20.1.1 via em0.0

root@CPE1> trace routing-instance VPNA 200.200.200.200 source 100.100.100.100
traceroute to 200.200.200.200 (200.200.200.200) from 100.100.100.100, 30 hops max, 40 byte packets
 1  172.20.1.1 (172.20.1.1)  7.916 ms  0.878 ms  1.110 ms
 2  *^C
root@CPE1> ...uting-instance VPNA 200.200.200.200 source 100.100.100.100  
traceroute to 200.200.200.200 (200.200.200.200) from 100.100.100.100, 30 hops max, 40 byte packets
 1  172.20.1.1 (172.20.1.1)  0.557 ms  0.358 ms  0.316 ms
 2  * * *
 3  200.200.200.200 (200.200.200.200)  9.889 ms  1.572 ms  1.183 ms

No comments:

Post a Comment